no magic catia logo

I have saved the project file with MagicDraw version 17.0.1 and now I can't open it with MagicDraw version 17.0. Are project files backward compatible?

Project files saved with MagicDraw version 17.0.1 or later cannot be opened with MagicDraw version 17.0 or earlier. Moreover, as of version 17.0.1, the project file inner structure has been changed.

Usually, projects of all MagicDraw versions are not backward compatible.

Please note that once a project file is saved with v17.0.1 for the first time, the backup file of a project created with an earlier program version is created automatically. The backup file is stored in the same location as the project file. While saving the project created with program version earlier than 17.0.1, a warning about the file format incompatibility appears.

Warnings about the file format incompatibility also appear when MagicDraw is downloading or updates automatically.

For more information or a quote
please contact
sales@nomagic.com
or call +1-214-291-9100.