no magic catia logo

I am trying to import an XMI 1.1 file with MagicDraw. I got a load error "Wrong XMI version : MagicDraw supports only Unisys XMI 1.0"

Up to MagicDraw 10.0 version, XMI v1.0, v.1.1 and v1.2 load, save and import is supported.

Beginning with MagicDraw 10.0 XMI 2.1 is supported. And only model load from XMI 1.0 - 1.2.

But if you are trying to open an Unisys XMI 1.1 (XMI v1.1 with Unisys extensions), it is not supported by MagicDraw, only Unisys XMI 1.0 can be loaded.

For more information or a quote
please contact
sales@nomagic.com
or call +1-214-291-9100.