no magic catia logo

Performance

This issue appears when MagicDraw Look and Feel is Windows. Please change the Look and Feel to Metal. For this, select Options > Look and Feel > Metal.

If you are running the Sun's JVM, set the following java properties in your mduml.properties* file: to the line JAVA_ARGS=-Xmx600M, append the string -Xss[stack size]

For example:

JAVA_ARGS=-Xmx600M -Xss2M

This sets java stack size to 2 megabytes.

 

* If you are using MagicDraw 17.0.5 or later, the name of the property file is magicdraw.properties.

If you are running the Sun's JVM, set the following java properties in your mduml.properties* file: in the line JAVA_ARGS=-Xmx600M, change the number of heap size '600' to maximal heap size in megabytes.

For example:

JAVA_ARGS=-Xmx800M

This sets java heap size to 800 megabytes.

If you get exception "java.lang.OutOfMemoryError: PermGen space" please, check if PermSize is specified in mduml.properties* file.

The JAVA_ARGS line should look like:

JAVA_ARGS=-Xmx600M -XX\:PermSize\=40M -XX\:MaxPermSize\=150M

If PermSize is specified in mduml.properties* file and the same problem still appears, the MaxPermSize should be increased. PermSize is part of heap size, so MaxPermSize should always be smaller than heap size specified with Xmx parameter.

For example:

JAVA_ARGS=-Xmx600M -XX\:PermSize\=40M -XX\:MaxPermSize\=200M

 

* If you are using MagicDraw 17.0.5 or later, the name of the property file is magicdraw.properties.

We noticed such behavior under Windows NT when mapped network drives are present, but a portion of them are offline. Try disconnecting all offline drives.

Try to start MagicDraw without direct draw, and edit JAVA_ARGS the line in the MagicDrawUML/bin/mduml.properties* file by adding -Dsun.java2d.noddraw=true.

The line should look like: JAVA_ARGS=-Xmx600M -XX\:PermSize\=40M -XX\:MaxPermSize\=200M -Dsun.java2d.noddraw=true.

 

* If you are using MagicDraw 17.0.5 or later, the name of the property file is magicdraw.properties.

This is a known Java bug. This issue will be fixed in MagicDraw 18.3, but in the meantime you can upgrade to the recommended Java version.

After installation, open <MagicDraw installation directory>\\bin, and modify the magicdraw.properties* file.

Change line JAVA_HOME= to correspond with the Java version you\'ve installed.

* If you are using MagicDraw 17.0.4 or earlier, the properties file is called mduml.properties.

This is a known Java bug. This issue is fixed in MagicDraw 18.4. If you are using MagicDraw 18.3 and earlier versions, you can use the recommended Java version that comes with installation.

Once you have installed the recommended Java version, do the following:

  1. Open the bin folder <MD install directory>\bin.
  2. Open the file magicdraw.properties.
  3. Look for the line "JAVA_HOME=" and change the Java version with the one you have installed.

In cases when MagicDraw is not responding, please, run submit_issue.exe. You may find it in /bin/ folder. In case there are processes, submit issue produces thread dump for it and writes it to md.log file. You can grab thread dump directly from Report an Issue frame, "MD log file" tab. Please attach thread dump to this issue report or send us md.log file. This log can be found in the user home directory ( /.magicdraw/ ).

While performing small ordinary tasks (not individual large operations, such as opening a large project or merging several large projects), modeling tool memory leaks may cause OutOfMemory exception errors. This is due to the cumulative effect of performing many small operations that normally do not cause any problems.

In order to analyze and fix the issue, more information is required. Please provide us with the following information:

  1. Can you reproduce the problem? If yes, what are the steps to reproduce it?
  2. If it is possible to reproduce it, send us the project file. We guarantee confidentiality, and shall sign a Non-disclosure Agreement at your request.
  3. Send us the memory dump file. It may help to detect the problem.

To create a memory dump file, please do the following:

  1. In the properties* file, append JAVA_ARGS parameters as follows:
    -XX\:+HeapDumpOnOutOfMemoryError -XX\:HeapDumpPath\=d\:\\snapshots
  2. Start your modeling tool.

The dump file will be created in the provided location – d:\\snapshots (please make sure that this location is available), if an OutOfMemory exception occurs. As the file may be large, please zip the created file, and upload it to the provided ftp server.

 


*

  •  For MagicDraw, the properties file is magcdraw.properties (mduml.properties for MagicDraw version 17.0.4 or earlier).
  • For Cameo Enterprise Architecture, the properties files is cameoea.properties.
  • For Cameo Systems Modeleer, the properties files is csm.properties
  • For Cameo Business Modeler, the properties file is csm.properties.

When you work with very large models or use a lot of diagrams at a time, the performance of MagicDraw may become slow. To increase an efficiency of modeling, we suggest the following solutions:

  • Increase a java heap size.
  • Do not keep unused diagrams open. Open project without loading diagrams. Your projects will be opened over a shorter period of time without opening a diagram as well as use less memory.
  • Increase an active validation period. MagicDraw takes less memory with increased active validations period.
  • Split the project to read only modules. Keep read only modules not loaded. This may help only if your project contains several parts with minimal dependencies between them.
  • Use Garbage Collector to free unused memory.
  • Turn of antivirus. Some antivirus software can cause significant performance decrease on project open and other actions.

For more information see "MagicDraw User Manual" > "Performance Improvement" section. Manual is available in < MagicDraw installation directory > \manual\

To solve the problem, we need a little input from you. We need to examine the log files to troubleshoot the problem. The following list outlines how to submit log files:

Generating a log file when the modeling tool freezes or performs slowly:

1. When a modeling tool runs slowly or freezes, open <modeling tool installation directory>\bin, and run submit_issue.exe several times. It dumps threads into the log file.

2. Click Help > About on the main menu of your modeling tool. In the open dialog, select the Environment tab and click the Log File link. The log file opens.*

3. Save the file and register an issue. Click Help > Report an Issue on the main menu of your modeling tool or go to http://www.nomagic.com/support.html.

*If a modeling tool is inactive, as of version 17.0.4, log file is stored in the following location:

  • Windows Vista/7/8 C:\Users\<USERNAME>\AppData\Local\.magicdraw\<md.version.number>
  • Windows 2000/XP C:\Documents and Settings\<USERNAME>\Local Settings\Application Data\.magicdraw\<md.version.number>
  • Windows NT4 C:\WINNT\Profiles\<USERNAME>\Local Settings\Application Data\.magicdraw\<md.version.number>
  • Other OS: <user.home>/.magicdraw/<md.version.number> 

By using Java VisualVM:

Modeling tools developed by No Magic Inc. are Java-based; thus, you can use the Java VisualVM program for performance issue examination. Data provided by VisualVM may help to explore issues accurately.

The following steps outline how to obtain the data from VisualVM:

Note. Please read the steps first to familiarize yourself with the whole procedure to gather more precise information. Step #8 should be started as soon as possible.

On Windows OS:

  1. Download and install the Java VisualVM with Java SE Development Kit (JDK, valid till version 1.8) or separately from https://visualvm.github.io/.
  2. Start Task Manager.
  3. Start Java VisualVM. If you selected the default location on the JDK installation process, VisualVM is located in C:\Program Files\Java\jdk<version number>\bin\ jvisualvm.exe. Otherwise, start the exe from your customized location.
  4. Start the modeling tool.
  5. In Task Manager, find the PID (Process Identifier) of your modeling tool.
  6. In Java VisualVM, find the Java process by the modeling tool PID in the Applications tree on the left (the same PID as in Task Manager) and double-click to open it.
  7. Click the Sampler tab and click the CPU.
  8. Initiate the action causing the low performance of your modeling tool.
  9. Wait until that action in your modeling tool is finished, then click the Stop button.
  10. In the CPU samples tab, click the Snapshot button. The snapshot is created in the Applications tree on the left.
  11. To save the snapshot, right-click it and select Save As to save the *.nps file.
  12. To register an issue, open the modeling tool. On the main menu, click Help > Report an Issue. The Report an Issue dialog opens.
  13. Fill out all necessary details, including the email address where the ticket link will be sent, and click Send. You will receive an email containing the ticket link in your inbox.
  14. Open the email and click the ticket link. Attach the *.nps file to send the issue to the support team. For more information about reporting an issue, please visit http://www.nomagic.com/support.html.

On Mac OS:

  1. Download and install the Java VisualVM with Java SE Development Kit (JDK, valid till version 1.8) or separately from https://visualvm.github.io/.
  2. Start Activity Monitor.
  3. Start Java VisualVM. If you selected the default location on the JDk installation process, VisualVM is located in /Library/Java/JavaVirtualMachines/jdk<version number>.jdk /Contents/Home/bin/jvisualvm. Otherwise, start jvisualvm from your customized location.
  4. Start the modeling tool.
  5. In Activity Monitor, find the PID (Process Identifier) of your modeling tool.
  6. In Java VisualVM, find the Java process by the modeling tool PID in the Applications tree on the left (the same PID as in Activity Monitor) and double-click to open it.
  7. Click the Sampler tab and click the CPU.
  8. Initiate the action causing the low performance of your modeling tool.
  9. Wait until that action in your modeling tool is finished and click the Stop button.
  10. In the CPU samples tab, click the Snapshot button. The snapshot is created in the Applications tree on the left.
  11. To save the snapshot, right-click it and select Save As to save the *.nps file.
  12. To register an issue, open the modeling tool. On the main menu, click Help > Report an Issue. The Report an Issue dialog opens.
  13. Fill out all necessary details including the email address where the ticket link will be sent and click Send. You will receive an email containing the ticket link in your inbox.
  14. Open the email and click the ticket link. Attach the *.nps file to send the issue to the support team. For more information about reporting an issue, please visit http://www.nomagic.com/support.html.

On Linux OS:

  1. Download and install the Java VisualVM with Java SE Development Kit (JDK, valid till version 1.8) or separately from https://visualvm.github.io/.
  2. Start System Monitor.
  3. To start Java VisualVM, execute the jvisualvm tool from the bin directory of the JDK. When the tool runs, the Java VisualVM window opens.
  4. Start the modeling tool.
  5. In System Monitor, find the PID (Process Identifier) of your modeling tool.
  6. In Java VisualVM, find the Java process by the modeling tool PID in the Applications tree on the left (the same PID as in System Monitor) and double-click to open it.
  7. Click the Sampler tab and click the CPU.
  8. Initiate the action causing the low performance of your modeling tool.
  9. Wait until that action in your modeling tool is finished, then click the Stop button.
  10. In the CPU samples tab, click the Snapshot button. The snapshot is created in the Applications tree on the left.
  11. To save the snapshot, right-click it and select Save As to save the *.nps file.
  12. To register an issue, open the modeling tool. On the main menu, click Help > Report an Issue. The Report an Issue dialog opens.
  13. Fill out all necessary details including the email address where the ticket link will be sent and click Send. You will receive an email containing the ticket link in your inbox.
  14. Open the email and click the ticket link. Attach the *.nps file to send the issue to the support team. For more information about reporting an issue, please visit http://www.nomagic.com/support.html.

In order to troubleshoot this issue, we will need the program’s log files (located in the install directory of your tool). Additional information might be required about the Java environment on which our modeling tools are based. The information we need is called the “heapdump” and can be obtained using the Java VisualVM program.

Please read and follow this procedure to install Java VisualVM and send this data to us (while the tool is running):

  1. Download and install the Java VisualVM with Java SE Development Kit (JDK, valid till version 1.8) or separately from https://visualvm.github.io/, if you do not have it.
  2. Start Task Manager or other appropriate tool depending on your OS.
  3. Start Java VisualVM. If you have selected the default location on the JDK installation process, VisualVm is located in C:\Program Files\Java\jdk<version number>\bin\ jvisualvm.exe. Otherwise start the jvisualvm.exe from your custom location.
  4. In the Task Manager or other program according to you OS, find the PID (Process Identifier) of your modeling tool.
  5. In the Java VisualVM, find Java process by the modeling tool PID and double click to open it.
  6. Right click the Java process and, from the shortcut menu, select Heap Dump. The heapdump file creates under your process.
  7. Save the heapdump file. Right click the heapdump and, on the shortcut menu, click Save As.
  8. Register an issue and sent the saved *.hprof file for the investigation. For this, on the main menu of your modeling tool, click Help > Report an Issue or go to http://www.nomagic.com/support.html.

When you report an issue with your modeling tool, Cameo Collaborator or Teamwork Cloud, always include related log files. Log files provide useful information that we need to investigate and troubleshoot your problem.

Accessing log files

  • For a modeling tool

Open your modeling tool and in the main menu go to Help > About <modeling tool name>. In the Environment tab, click the link provided in the Log File line to open a log file.

  • For Cameo Collaborator

Go to Alfresco Community installation directory, and obtain the alfresco.log, share.log and solr.log files.

Go to <Alfresco Community installation directory>\tomcat\logs, and obtain the alfrescotomcat-stderr.log, alfrescotomcat-stdout.log and catalina.log files.

  • For Teamwork Cloud

Go to <user home directory>\.twcloud\<server version>, and obtain the server.log and client.log files.

Go to <Cassandra installation directory>\logs on Windows OS or /var/lib/Cassandra on Linux, and obtain the Cassandra log file.

Generating a log file

If the performance of your modeling tool declines or it freezes, go to <modeling tool installation directory>\bin, and run the submit_issue.exe file several times. It dumps threads into the log file of your modeling tool. Then you can access the log file, as described above.

Java crash log files

If your modeling tool crashes (disappears), try searching for Java crash log files. They are stored in the running location of the modeling tool, e.g., the <modeling tool installation directory>/bin or <modeling tool installation directory> directory. The names of these log files start with "hs_err", e.g., hs_err_pid15693.log. If you find the Java crash log file, the reason your modeling tool crashed was that Java crashed.

For more information or a quote
please contact
sales@nomagic.com
or call +1-214-291-9100.