no magic catia logo

Other Issues

The problem occurs, when during the installation, the default language is changed. This problem is related to Java 1.7.

The solution is to install MagicDraw* again without changing the default language. Then, you can change the languange after the installation. To do this, on the Options menu, click Environment, and then in the General options group, change the Language property.

 

* This is valid for all MagicDraw-based Cameo Suite products.

MagicDraw uses the simplified metamodel profile that has no attributes visualized. But the attributes still exist in the code.

As a solution we suggest you to use the sample of the full metamodel profile, because it has no striped attributes. We use this profile mainly as a reference when writing OCL constraints.

Download the sample of the full metamodel profile, using the MagicDraw capabilities:

1. From the Help menu, select Resource/Plugin Manager.

2. Click the Check for Updates button.

3. Wait while the checking for updates is finished.

4. In the Filter box, choose All Resources.

5. In the product list, scroll down to the UML Standard Profile with attributes for OCL and select it.

6. Click the Download / Install button.

The full metamodel profile will be stored in the " /samples" directory.

Merge functionality can be employed for this. Choose the Tools -> Project Merge menu item, specify the source project (the project from which you want to port changes), the target project (the project to which you want to port changes), and an empty ancestor project. Then press the Merge button and you will be provided with the standard Merge dialog, which allows you choosing which changes should be merged-in.

Font and other UI style options can be changed by changing look&feel theme (Metal theme should be used). It can be changed from the Options > Look&Feel > Metal. Theme can be customized in theme customization dialog which can be opened from Options > Look&Feel > Customize.

Please be sure that you got the installation file from www.nomagic.com.

In this case we can confirm our software is not infected by a virus and it is safe to use it.

One known reason why antivirus software in rare cases identifies *.exe files as suspicious is because of Norton antivirus software issues where a legitimate file is misidentified and subsequently quarantined. More can be found at http://securityresponse.symantec.com/security_response/writeup.jsp?docid=2010-090201-1030-99&tabid=2. As they say in above document suspicious level is very low.

Workarounds for this issue are available. We suggest to:

  • ignore suspicions from Norton antivirus.
  • use the "no install" installation (*_no_install.zip).
  • Symantec suggests disabling the auto protection option and checking if the issue is resolved.

Let us know at This email address is being protected from spambots. You need JavaScript enabled to view it. if more help is required.

We are working with Norton antivirus to eliminate this issue.

A relative path begins at a current folder of the hierarchy (i.e., a project or MagicDraw installation) and specifies the file's location from there.

You add a hyperlink with a path relative to the MagicDraw installation folder. For example, the path file://sample.jpg refers to the image that is stored in the MagicDraw installation folder.

When creating a hyperlink to the file stored in the same folder with the project, a path relative to that location is always suggested. A relative path can also be specified manually. For example, the path file://MyPictures/sample.jpg refers to the picture stored in the My Pictures directory located in the same folder as the project.

For more information or a quote
please contact
sales@nomagic.com
or call +1-214-291-9100.