no magic catia logo

After updating MagicDraw to version 17.0.1 exceptions can be shown on different actions.

After updating MagicDraw to version 17.0.1 exceptions can be shown on different actions. The exception stack trace may look like :

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
at com.nomagic.utils.Utilities.invokeAndWaitOnDispatcher(Utilities.java:1578)
at com.nomagic.magicdraw.core.project.ProjectsManager.setActiveProject(ProjectsMana ger.java:315)
...

OR

java.lang.AbstractMethodError
at com.nomagic.magicdraw.core.project.ProjectsManager.fireProjectPreActivated(Proje ctsManager.java:1352)
at com.nomagic.magicdraw.core.project.ProjectsManager$2.run(ProjectsManager.java:26 9)
at com.nomagic.utils.Utilities.invokeAndWaitOnDispatcher(Utilities.java:1562)
...

You are using incompatible plugin e.g. Cameo Simulation Toolkit 1.1, Cameo Data Modeler 16.8, EstimIX, ExtendIX, or other. Those plugin versions are not compatible with MagicDraw 17.0.1.

Please update or remove incompatible plugins from Help > Resource/Plugin Manager > Click the button "Check For Updates" > and download compatible version OR remove incompatible plugin from the MagicDraw.

Plugins compatibility can be checked here.

For more information or a quote
please contact
sales@nomagic.com
or call +1-214-291-9100.